Results 1 to 6 of 6

Thread: Frame rate choppiness after deinterlacing

  1. #1
    Join Date
    Nov 2005
    Location
    PMB, KZN, South Africa
    Posts
    18

    Default Frame rate choppiness after deinterlacing

    I captured to DV-AVI and it is heavily interlaced when viewing on PC (as expected). When previewing through software such as WMM and Nero ShotTime, however, the playback appears progressive (so I asssume deinterlacing is done in realtime), but the framerate appears just as I would expect. After encoding and deinterlacing however, playback is just not up to standard - it is choppy and seems more like a slideshow. On pause, the image looks as though two frames were mixed together.

    Is there any way to emulate the far superior playback of DV-AVI through WMM and Nero after encoding. Resultant file size not too important. I would like the video to be progressive, though.

    I have already tried encoding through VirtualDub and WMM.
    Many thanks,
    Justin

  2. #2
    Join Date
    Nov 2005
    Location
    Bristol uk
    Posts
    8,938
    Blog Entries
    1

    Default

    May be a player problem. If i get a choppy look I always check my cpu use, if it is 100% then that may be the probelm.

  3. #3
    Join Date
    Nov 2005
    Location
    PMB, KZN, South Africa
    Posts
    18

    Default

    No, checked that. My computer (HDD and processor, RAM) is handling the video very well, not even breaking sweat. It's the actual video itself...

    I think the proof is that when I pause I see an image that seems like two separate frames in one. For example, a running man would appear as two running men in a paused frame. This is not the case in the DV AVI preview.

    Motion is not done well at all in the encoded progressive format. Would this be a result of deinterlacing or compression? I have used a multiude of high quality settings to encode - no change.

  4. #4
    Join Date
    Nov 2003
    Location
    Kent
    Posts
    11,526
    Blog Entries
    24

    Default

    Compress to WMV using windows media encoder (or software of your choice) and post here for us to see.

  5. #5
    Join Date
    Nov 2005
    Location
    PMB, KZN, South Africa
    Posts
    18

    Default Fixed one issue

    Ok I fixed 1 issue, the problem of the "smudge" - I changed deinterlace (in virtualdub) off the setting "blend" - I think it is a very stupid method. Sure the resolution doesn't suffer, but I hate the blurred frame when paused... I feel so stupid, this should have been obvious to me.

    I still haven't got the motion to look as smooth as it does on the WMM preview, however. Does anyone know the inner workings of whatever filter is used to show the preview? It looks amazing and plays so smooth. I also noticed that if I play a video in WMP at the same time, the preview in WMM appears interlaced again so it is definitely some sort of filter or something that is shared between the two...

    The motion is still "choppy", which I assumed was because of the "effective" halving of the frame rate, but when I tried to convert the clip to 50fps, there was still no difference. Somehow I have to get the deinterlacer and the compressor to work together to convert each field into a separate frame... Any ideas?

    One last thing; I can't seem to change the method of deinterlacing in WMM - it seems to only be able to use blend. Same with Media Encoder. Any way I can change this?

    PS: File will be uploaded to Yahoo! Briefcase shortly. Will post link soon.
    Justin

  6. #6
    Join Date
    Nov 2005
    Location
    PMB, KZN, South Africa
    Posts
    18

    Default Ghosting

    That problem I "solved" is called ghosting... Sorry I didn't associate the term until now.

    What is a good place to host the file? Sorry, haven't done that before?

Similar Threads

  1. Frame rate help please
    By ici in forum Pinnacle Studio, Edition including Avid Xpress and Liquid
    Replies: 3
    Last Post: 04-17-2006, 06:32 PM
  2. Looking for a camera that can shoot at a faster frame rate..
    By Chris Oakley in forum Technology advice and tips
    Replies: 6
    Last Post: 02-13-2006, 04:04 PM
  3. Frame rate choppiness after deinterlacing
    By jsaonline in forum General video editing software help and advice
    Replies: 0
    Last Post: 12-01-2005, 06:02 AM
  4. non-standard video frame rate
    By nicko in forum Pinnacle Studio, Edition including Avid Xpress and Liquid
    Replies: 3
    Last Post: 03-09-2004, 05:43 PM
  5. Frame skipping/choppiness after transitions in WMM2
    By kappa12 in forum General video editing software help and advice
    Replies: 0
    Last Post: 02-24-2004, 11:13 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •