Hello! I have an .srt file with Chinese subtitles, which I need to embed into a short video (avi, mpeg, mp4, etc. I have converted it to many formats).

Initially, my OS did not support Asian languages, so I had to install additional Windows packages. I tried to embed the file using VLC, Subtitle Workshop, Aegisub, SubtitleEdit, Moviesubtitler, and some more, but I got gibberish characters. Then I did exactly what mentioned here:

"I was having the same problem, but after much searching, I found some things that helped solve it for me:

First, I think the reason your .srt file is garbled is because it isn't encoded right. On the advice of another forum, I downloaded the trial version of NJStar, http://www.njstar.com/cms/ (incidentally, this program can also do Japanese & Korean.) Use this program (it's Universal Code Converter) to convert your .srt file to UTF8 --- it will create a new file in a separate folder (easy to find), with the same name as your original. Now when you open the *new* file in Notepad, you should see the Chinese characters.

Next, you need to set up VLC: Go to preferences, and in Subtitles/OSD, change Default Encoding to UTF-8. Set the preferences to "show all," and then go into Video - Subtitles / OSD and change "text rendering mode" from "default" to "Freetype2 font renderer." Now, expand the Subtitles/OSD menu and go down to "Text Rendering." Choose a Unicode font to display. (You may have to type out the file path for the font; I wasn't able to browse for it anyway. Of course, you'll want to choose a font with Chinese characters. I chose SimHei -- C:\Windows\Fonts\simhei.ttf).

Finally, save preferences, and restart VLC. When you begin your movie, simply choose the .srt file NJStar made for you via the Video menu, Subtitles track, Open file.

Worked for me, hope it works for you too."

In fact, it worked. I was able to view the Chinese characters in the video applications. However, while trying to embed the file, no success. Again, non sense characters. Any idea what can be wrong? I have been searching where the problem is for more than 2 days.

Thank you!