I've had this problem as well with DVDs. Results seem to improve as suggested elsewhere by disabling re-sample. Click first frame - shift - click last frame, to quickly select all frames. Then edit/switches/disable re-sample.