Results 1 to 2 of 2

Thread: Sony Vegas Not Importing Properly

  1. #1

    Default Sony Vegas Not Importing Properly

    Hi guys. I'm new to using Sony Vegas as I recently bought Sony Vegas HD Platinum 11. I've been recording some gameplay footage using my new Hauppauge HD PVR 2 gaming edition and tried to edit the footage in Vegas. But when I import the file it only imports the video, not the audio. The file type is M2TS. I've googled the issue but everything I've tried has failed. Someone suggested converting the file to avi but I'm not spending 40 on more software after having just bought the HD PVR, a mic, a 2tb hdd and Sony Vegas, which I bought so I could edit videos, which I apparently can't do.

    Any help would be appreciated.

  2. #2


    You may be having issues because you have recorded the game play in what is called transport stream ie this is the same as transmitted HD TV. This format is not really suitable for editing video. Is there a way to save the video in another format or is that all that the Hauppauge can save in. A .m2ts file is what is called a container and inside it will have a video with a specific codec. This codec is what you need to be able to edit your videos. If you can't find the right codec you can get free video converters, you could try Any Video Converter.

    If you can, find the right codec first. You can use a program call GSpot to find out what codec is being used and it will tell you if you have the codec installed on your computer.

Similar Threads

  1. Why wont Sony Vegas render videos 'properly'?
    By TheBenbig1 in forum Sony Vegas video editing apps
    Replies: 7
    Last Post: 10-09-2012, 07:13 AM
  2. Do you need a good video card to use Sony Vegas Pro properly?
    By Sarah & Allison in forum Sony Vegas video editing apps
    Replies: 8
    Last Post: 11-22-2010, 07:20 PM
  3. Files not importing into Vegas!
    By n1rv4n4 in forum Sony Vegas video editing apps
    Replies: 0
    Last Post: 02-20-2010, 04:55 AM
  4. Sony Vegas doesn't render properly
    By PePe in forum Sony Vegas video editing apps
    Replies: 2
    Last Post: 09-05-2009, 11:52 PM
  5. Sony Vegas 8.0 - audio/video not grouped properly
    By crazyporridge in forum General video editing software help and advice
    Replies: 3
    Last Post: 02-14-2009, 02:44 PM


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts