Results 1 to 7 of 7

Thread: No sound in rendered comp (AE CS4)

  1. Default No sound in rendered comp (AE CS4)

    I'm away working at sea and trying to find my way around After Effects which I'm pretty impressed with. However, my first attempted render had no sound. During RAM previews it had sound, and I even saved a RAM preview which had sound (I'm not really sure exactly the difference between a saved RAM preview and a render, but maybe thats for another day.).
    I accept that I've probably done something dumb, but I don't even know where to start so any suggestions would be very much appreciated.
    Oh, and Happy New Year!

  2. #2


    I can't help you with AE as I've never used it. BUT it sounds like you muted the computer.

    Happy New Year to you.

  3. Default

    MB. Thanks for speedy reply. I had'nt muted the computer, but I will be delighted if it turns out to be as easy as that.

  4. #4


    The first place you want to look is in your render settings. Have you got the "Audio Output" box checked in the "Module Settings" in the "Render Queue?"


  5. Default

    Well, I said I like simple!
    Thanks for that David, I think I've got it.
    The instruction book I'm using advocates starting each project with Adobe default settings by pressing Cont/Shift/Alt on start up. I thought (wrongly?) that I couldn't go too far wrong with that.
    The output module setting in "Render" was set to "Lossless" (and I've no idea yet what that means), so I changed it to "DV PAL 48khz" did a quick render and voila: Sound!
    I'd like to know what you think of the solution, but it appears to work so once again thanks for that. This really is a great forum.

  6. #6


    I wouldn't advocate always starting with default settings, over time you'll find lots of different settings that you use most often for your purposes and ways to change them to be the defaults for you. I'd advocate getting an awareness of this as early as possible, it will help you get a greater understanding of what's going on behind the scenes.

    Lossless means it's uncompressed video. For many reasons, unimportant at this time, exporting at the highest possible quality is often desired. So it makes sense that After Effects defaults to lossless exports. Normally After Efftects isn't really related to working with Audio (not much anyway), normally that is taken care of in an Non Linear Editor, so it also makes sense that it defaults to lossless without audio.

    You asked earlier about your RAM preview, when you create a RAM Preview you are essentially exporting a video using a lossless codec. You aren't exporting to a DVD or hard disc or anywhere that you can source later, just tempoarily to your RAM, so the more RAM you have the longer you can preview.

    When you save a RAM preview, what your actually doing is creating a file from the information you have saved to your RAM on the hard disc. It's not quite copying from RAM to disc, but if you think of it like that you can see why it makes sense. Lets say your making changes to an effect, or some graphics, all day long. You've saved numerous RAM previews between adjustments and you hit one that you want to show someone for some reason. Instead of starting the rendering process again and exporing a video from the render queue you just hit "Save RAM Preview" and it means you don't have to wait for it to do all the calculations as it exports again.

    As for your solution using "DV PAL 48khz". It depends what your doing, but you may well find that it's what you use most of the time. If you havn't seen already, in the bit you changed from lossless, you can click the word lossless (not the list, beside it) and it opens up a box where you can change lots of custom settings, in here you'll see the check box for audio. So if you wanted you could export a lossless video with audio, but you'll also notice that the lossless setting resulted in much bigger file sizes than the PAL DV settings.

    You'll probably find you don't need to be in there at the moment, your settings you found may do you fine for some time. But it's well worth learning what's going on with all this technical stuff.

    For now, if you open up the list of preset settings (like you done before), and select "make template" from the bottom of the list and change the"Movie Default" to "AVI DV PAL 48KHZ" you'll find you don't need to change it every time you add something to the render queue.

    Something esle you should be aware of, above the "Output Module" is the "Render Settings", by default this is set to "Best Settings", the only thing here that should be of interest to you, as yet, is that it exports progressive. If your using DV PAL then it could be better to have it exporting interlaced fields.

    If your making video's to end up online or to be viewed on a computer, then definately leave it at "Best Settings"
    If your going to DVD then you might want to change this, to do so just change it from "Best Settings" to DV Settings".

    Last edited by david walsh; 01-02-2011 at 10:00 PM.

  7. Default

    Thanks very much for that explanation, its been a great help to me and I'm sure to others who may read it at some point.

Similar Threads

  1. Comp Entry
    By IConyers in forum 3:33 - The (Late) Summer Video Contest 2009
    Replies: 3
    Last Post: 10-12-2009, 04:54 AM
  2. Comp Winners
    By indiandy in forum User Videos
    Replies: 4
    Last Post: 10-12-2006, 07:32 PM
  3. BBC comp
    By Marc Peters in forum Forum Announcements and News
    Replies: 3
    Last Post: 09-14-2005, 03:30 PM
  4. how do you transfer a dvd to ur comp...
    By xbackstreetgirlx in forum Adobe Premiere, Premiere Elements, and After Effects
    Replies: 1
    Last Post: 03-15-2004, 08:19 AM


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts