Hi guys, sorry to kinda just barge into your forum but I need help. I'm trying to finish a comedic project of mine before my next year of uni (media production) starts. So hi to everyone here, but im in a real pickle.

Right I purchased an Easycap usb.2.0, A.V out to USB in video card (i believe its a video card, or a capture card)

This is the product I purchased.

EasyCAP USB 2.0 Video and Audio Capture Card: Amazon.co.uk: Electronics@@AMEPARAM@@http://ecx.images-amazon.com/images/I/41VCRLHdA5L.@@AMEPARAM@@41VCRLHdA5L

The software came with a set of drivers, USB Audio Interface, USB Composite Device and USB2.0 video capture controller.

Now the first two install without a problem. But the third one is the one I'm sure is ruining everything. It begins installing as USB2.0 video capture controller fails and then installs as Syntek1150.

I've heard I need to change this to Syntek 1160, but I can't find the actual driver on the internet, just set up files with no content. Any attempts to change the drivers are ignored by vista, which keeps deciding the current choices are the best fit.

Odd as this may be.

I'm including some screenshots and I'll answer any questions, i've already tried reinstalling, checking the drivers are up to date and manually selecting the drivers from the disc. I've tried downloading other drivers and making windows search there, but windows keeps coming to the conclusion the Syntek drivers are the best choice and refuses to let me switch them.

I've included some screenshots and I will attempt to do a screen capture video later to show the problem I'm having specifically.

Any help would be life saving, I have a deadline for tuesday.

Note this card does not seem to be the same as Ezcapture, a device people seem to confuse.

Thanks for helping me out if you can, i'll be sure to return to this forum with the finished film for some good criticism.