Page 1 of 5 123 ... LastLast
Results 1 to 10 of 48

Thread: Youtube upload: audio out of sync with Video

  1. Default Youtube upload: audio out of sync with Video

    We uploaded our new band video to YouTube today & the audio is out of sync with the video.
    We rendered it using the Sony AVC mp4 (Internet16:9 25p) template

    Audio: 128 Kbps, 48,000 Hz, 32 Bit, Stereo, AAC
    Video: 25 fps, 1280x720 Progressive, YUV, 10 Mbps
    Pixel Aspect Ratio: 1.000

    which we used for our last video & which uploaded ok.
    As this is a YouTube preferred format we cant understand what we've done wrong.
    Could any nice gentleman help us?


    Sarah & Allison & Tina

  2. #2
    Join Date
    Jan 2005
    Warsop, Nottinghamshire.
    Blog Entries


    If the video plays correctly for you at home, I would guess you haven't done anything wrong. I've seen out of sync on my own stuff only once (but years ago), I deleted, re-uploaded and it was fine.

  3. Default

    Thanks Andy
    will try uploading again tonight


  4. Default

    No, it's still out of sync!

    There are 2 things which might be red herrings but I'll mention them anyway,

    Every time we open Vegas we get a nag screen pop up saying "your 3ivx trial has expired" (we dont even know what this is?) &

    We have 4 audio files in the Vegas project we are rendering from, 3 are .wav & 1 is .mp3. Is that significant?

    If anyone's got any other suggestions we'd be very pleased to hear them, we've spent months on this video

    Sarah & Allison & Tina

  5. #5


    Try this: Take your GOOD, in-sync file and your latest outta-sync file and run GSpot over them and get back here with what you are seeing as part of the GSpot analysis.

    Another thought. Just where/how are you downloading/viewing the file? Are you seeing out of sync on other people's work?

  6. #6


    Just re-read your post. You have an MP3 being rendered to an MP4 format? - Yes? Not my area of expertise here, but I'd think that could be an issue. First try rendering JUST using WAV and see what that does and THEN secondly try rendering JUST using the MP3. What results in sync do you get? Maybe you could render the MP3 to wav and then use that newly created WAV?

  7. Default

    Thanks Grazie for looking at this.
    I have a wav version of the mp3 file so will substitute that & upload the video to see if it makes any difference.
    I have downloaded Gspot but although I can see how to use it to check the file before the upload to YouTube how do I use it to check the uploaded video thats gone out of sync?
    To answer your other question, we are viewing the video on YouTube & our other uploaded videos look fine.


  8. #8


    Does GSPOT show the same (or different) Codecs used between this; and your earlier uploads? (GSPOT will show two Codecs; one for the Video, the other for the Audio).

    On YouTube; does the clip sound ok - and then become increasingly out of sync? Or does the delay start at the beginning and remain the same level of uncync?

    I am wondering if the 3ivx used to be the codec used; but having expired, Vegas is using another codec to create the AAC part of the file.

  9. Default

    Thanks Tim for the input
    GSpot shows the same codecs for an earlier video & this new one.
    The only difference I can see is however is that the audio info shows the new one as 48,000hz 128kb/s, whereas the old video was 41,000 hz.
    Is that significant? They are both mp4 files.
    The uploaded YouTube video is out of sync all the way through.
    I've found the 3ivx zip in the downloads folder but dont remember how it got there, but it does say 3ivx_MPEG4_502_trial.


  10. #10


    YouTube suggest sync problems arise from incompatible audio codecs.
    Audio out of sync - YouTube Help

    They neither suggest 41k or 48k. They claim to like 44k.
    Optimising your video uploads : Learn More - YouTube Help

    Here is a recent thread where the uploader found 48k was out of sync, but 41k was ok.
    Audio is out of sync with video - YouTube Help

Page 1 of 5 123 ... LastLast

Similar Threads

  1. Export Settings for youtube upload
    By kevinkhan in forum Adobe Premiere, Premiere Elements, and After Effects
    Replies: 4
    Last Post: 04-25-2011, 03:20 AM
  2. Video Upload To Youtube
    By laurie_hammy in forum Sony Vegas video editing apps
    Replies: 13
    Last Post: 01-20-2010, 11:08 AM
  3. YouTube wont let me upload my video
    By barrychuckle1411 in forum Forum Announcements and News
    Replies: 7
    Last Post: 03-26-2009, 08:57 PM
  4. [Question] How to upload on youtube?
    By Kirghiz in forum Sony Vegas video editing apps
    Replies: 1
    Last Post: 01-23-2009, 03:22 PM
  5. 3 out of 4 video files wont upload to YouTube...
    By Nintendo Fan Mike in forum General video editing software help and advice
    Replies: 2
    Last Post: 10-12-2008, 10:27 PM


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts