Results 1 to 10 of 10

Thread: This will eventaully kill me. MULTIPLE FILETYPES IN VEGAS 9. (It should work, right?)

  1. Default This will eventaully kill me. MULTIPLE FILETYPES IN VEGAS 9. (It should work, right?)

    Hi!

    After nearly three weeks spent ripping my hair out, I have finally decided to give in and ask for help. There, I said it. I need help. I am in desperate need for help. I really been trying to solve this myself, but itís just to much information to process. I am lost in the jungle of Project Properties, Encoding settings, Pixel Aspect Ratios, Media Properties and DVDīs. I knew to little regarding this in the beginning. I reckon that most of you guys are more educated in this area then myself, and I now wish that someone will find it in their heart to help me out. Thanks so much in advance.

    Ok, here we go;

    I am editing a movie. A skateboarding movie, to be precise. Source material comes from a bunch of people, and is filmed with a couple different cameras. Source material therefore contains multiple file formats. This consists of mainly four types, by witch I easily can combine three of them, but the third is REALLY KILLING ME.

    I work in Sony Vegas 9. My final output will be Standard DVD and Streamed Vimeo. My problem is only visible on DVD. I have been outputting a couple of test mp4īs. All of them have been pretty much ok.

    These are my four types of source material:

    PAL DV
    (filmed with my own camera)
    Shows up in G-spot as;
    Lower field first / Pixel Aspect Ratio = 1.067 / 720*576 / 25.000 fps

    MPEG 2
    (filmed M2TS with my friendís camera, converted since my computer couldnít handle it.)
    Shows up in G-spot as;
    Lower field first / Pixel Aspect Ratio = 1.067 / 720*576 / 25.000 fps

    PAL DV
    (filmed with the camera thatís later will be causing all the trouble)
    Shows up in G-spot as;
    Lower field first / Pixel Aspect Ratio = 1.067 / 720*576 / 25.000 fps

    >>> PAL DV WIDESCREEN
    (This is the type who I just CANT fit with the others)
    Lower field first / Pixel Aspect Ratio = 1.422 / 720*576 / 25.000 fps

    Here is a sample of said format:
    http://www.ganget.net/sample.avi

    -------

    After working pretty much non-stop for all to long, I can now easily fit the three first filetypes into the same timeline in Vegas. I can edit them, and put out a decent Standrad DVD and make a pretty ok mp4. BUT, then comes filetype number four. Feels like I have been trying every last setting. Mp4 seems ok, but I just canīt fit it with the rest of the files on a DVD. Filetype four clips seem to have some sort of Interlace error, and vertical lines are all to visable in clips witch contains motion. Ive been trying the Reduce Interlace flicker option in Vegas. It leaves me with no lines, but with a blur and a motion studder that I just cannot live with. Sadly.

    Another problem appears when I try to fix it. Thing is, since I didnít film the clips myself or own the camera myself, I donít now much about these files. I just found out the camera model, witch is a Sony HDRĖHC5E. The first week of trying to solve my problem I was therefore sure that my issue steamed from it being a HDV camera hence producing 1080i clips. I am not so sure about that any longer. Judging by what Gspot, Vegas and TMPGenc tells me, the file seem to be Widescreen DV, same field order as regular DVīs but different Pixel aspect ratio. How is this even possible? I guess that my friends have captured the footage in some strange way.

    I would be forever grateful if someone could tell me just why I canít fit these files into my DVD. I have been trying nearly every combination of settings. Ive been messing with Project Properties, Media Properties and Encoding Settings in Vegas. Nothing Works. Absolutely nothing. Where does the lines come from?

    (For those familiar with Vegas)
    1. What should my project setting be?
    2. Am I recommended to mess with the individual clip settings in the Project Media Window?
    3. What should my rendering MPEG2 for DVD settings be?

    Thanks soooo much in advance. I love you all for even reading this! If someone answers (and MAYBE eventually help me solve it) I would probably explode in pure happiness. If more information is needed, just tell me and I find it out.

    Have a nice day!

    /Storhuvve

  2. #2

    Default

    You've been at this for three weeks !!! You sure have got some tenacity.

    This kind of interlace artifact is commonly due to the wrong field order. I played with your sample clip in Vegas and rendered it with upper field first. To my eyes it looks a little better but it hasn't solved the problem.

    The only thing I see wrong with your settings was the pixel aspect ratios seem different to my standard settings in Vegas example PAL DV Windscreen is 1.4568 and normal PAL DV is 1.0926 I don't know if this make any difference or not or why they would be different.

    After 3 weeks of trying various settings I'm sure you've tried about everything.

    Unfortunately this is about the extent of my knowledge. After such a heart felt plea for help I didn't want you to think it has fallen on deaf ears here in this forum.

  3. #3

    Default

    I haven't looked at your clip yet (downloading now), but the first thing that springs to mind is; If one file type is causing all the trouble, why not convert it to something else that works with the others? Experiment with a small clip to find what works.

  4. #4

    Default

    vertical lines are all to visible in clips

    If verticals become JAGGED when there is movement, then in the Project settings set the RENDER QUALITY to BEST and try a sample render to see if that fixes it.

  5. #5
    Join Date
    Feb 2006
    Location
    Surrey, UK
    Posts
    10,847
    Blog Entries
    1

    Default

    Quote Originally Posted by storhuvve View Post
    Judging by what Gspot, Vegas and TMPGenc tells me, the file seem to be Widescreen DV, same field order as regular DVīs but different Pixel aspect ratio. How is this even possible? I guess that my friends have captured the footage in some strange way.
    Just to set your mind at rest (at least a bit) this is absolutely standard settigs for Widescreen Standard Definition PAL DV. (To clarify, the ONLY difference between 16:9 and 4:3 DV footage is the Pixel Aspect Ratio).

    So, your friend has recoreded in DV rather than HDV. There should be absolutely no problem matching this at all (other than needing to crop the sides if making a 4:3 or add bits either side to the other footage if making a 16:9. I used to do this all the time (as my camera would randomly decide to reset itself to 4:3 without me noticing - not good for serious film, but OK for family snaps.
    Tim

  6. #6
    Join Date
    Feb 2006
    Location
    Surrey, UK
    Posts
    10,847
    Blog Entries
    1

    Default

    I've played around a bit with your clip. So far I have not rendered to Mpeg2 for DVD (you said Mpeg4, but I don't think you meant that)

    Just rendering to AVI I have no problem at all.

    The jagged vertical lines are clearly visible in the preview screen, but this is just a preview and is not what you end up with when rendered.

    I create a 4:3 project and import your 16:9 media.

    If I crop your media using the Pan & Crop tool and the 4:3 TV setting, the rendered result is fine.

    If I don't crop it, the rendered result wil have jagged verticals UNLESS I use one of the de-interlace method, in which case all is fine.

    Also bear in mind that MPEG2 for DVD should be interlaced, and so it may not look right on your PC screen (depending on how good your media player software is at de-interlacing) yet look fine once played in a commercial DVD player.

    In order to understand what's going on here you could do with reading up on interlacing. However, in a nutshell the "problem" I experienced when not cropping the 16:9 media comes about thus:
    (PAL details used)
    Your image, whether 4:3 or 16:9 is made up of 576 horizontal lines. But only half of those lines are used in each "scan" which happens 50 times per second - the odd lines on one scan and the even lines on the next and so on.
    So, to get a complete 576 line picture you need one odd and one even scan. THis is known as interlacing.
    However, if the subject moves, it will be displaced slightly between te first and the second scan. As the scans are horizontal, the problem shows up as jagged edges or "combing" on vertical lines.
    A TV plays back alternating odd and even scans - mimicing the way the image was recorded and so all is well - so long as we don't much about with it in the meantime.

    BUT If you take your 16:9 image and fit it width wise into a 4:3 screen, you are shortening it vertically - your 576 lines are now squeezed into fewer lines. Thus the lines no longer match up ad you will get dreadful "jaggies".

    If, on the other hand, you simply cut off the left and right sides of the image, leaving the 576 lines filling exactly the same amount of vertical space as they did before the crop, each line will match 1:1 and you will not get the problem.

    De-interlacing, attempts to overcome this problem buy articficially onstructing "progressive" frames - where all 576 lines are used in one "scan". Because this is done in software it can lead to a softer image.

    De-interlacing must be done if you are doing ANY vertical resizing on interlaced footage.

    And don't worry, I remember going through similar problems (and also struggling for weeks) when I was trying to get to grips with this stuff.

    I can't say I reall have got to grips with it, but I seem to know enough that I don't get the problem any more.

    As a postscript, I would recommend render your project to AVI first. Then create your MPEG-2 for DVDs from that completed AVI.
    Tim

  7. #7

    Default

    Nice explanation Tim - thumbs up!

  8. Default

    Ok.


    I will return to this thread later, since I am in a awesome hurry right now. But I just have to drop by and say; Thank you, TimStannard. You are the greatest man who ever lived. Seriously. I did it. As happy as I am now, justifies every little piece of total defeat I experienced during the last weeks. THANK. YOU.

  9. Default

    Yes, not in hurry anymore and back in a thread for whom I might need to apologize for keeping on the first page of the forums. I just felt I needed to come back and thank you all properly, and give you a little insight in witch way I choose.
    After much thought, I tried out the deInterlace method. Worked out perfectly, and I kinda understood what I was doing too. Never could have done it without you guys. The decision was mostly based upon the fact that I really liked my "sides" on my PAL DV WIDESCREEN clips. I wouldn't want to lose them, even though I understand that I will probably drop a little in sharpness going the deInterlace way. Anyways, a testedit with all of my formats (even added pictures/cellphonevideos/music and all kinds of crap to be sure) plays perfectly. THANK YOU SO MUCH!!!

    Just to set it straight;


    When choosing DeInterlace method in Vegas, the program only messes with the clips that doesnt add up, right? In this case the 1,48568 pixel aspect ratio ones?

    Also, (and this is not totally super important) but when exporting a mainconcept mp4 (witch I gather is the best rendering setting for streaming and "put-filing"), should I just set the project properties to None: progressive and export a Non-Interlaced file? Or is it recommended that I keep my field order? I know Progressive scan is preferable for computers, so this question is probably unnecessary.

    Once again, thanks! I dont want to sound overly dramatic over here, but I really feel that this is the greatness of the Internet generation on live display.

    Have a nice day!

  10. #10
    Join Date
    Feb 2006
    Location
    Surrey, UK
    Posts
    10,847
    Blog Entries
    1

    Default

    It's successes like this that really inspire me to try to help others (and presumably inspire others to help the likes of me). It's so satisfying to witness someone make a sudden breakthrough in their understanding not least because I can remember having gone through similar torture myself many times and then finally had my eyes open.

    Glad you're fixed.

    Quote Originally Posted by storhuvve View Post
    Just to set it straight;

    When choosing DeInterlace method in Vegas, the program only messes with the clips that doesnt add up, right? In this case the 1,48568 pixel aspect ratio ones?
    I believe it will de-interlace everything - otherwise the setting would have to be per event rather than apply to the project.

    Forgive me for not responding to your second question, but I'm not the best cookie in the shop when it comes to output formats, so i'll leave it to others to respond.
    Tim

Similar Threads

  1. Apply transition to multiple tracks in Vegas Pro 8?
    By evilc in forum Sony Vegas video editing apps
    Replies: 1
    Last Post: 06-04-2008, 06:35 PM
  2. Moving multiple clips in Vegas 8.0
    By OdogMcAdams in forum Sony Vegas video editing apps
    Replies: 3
    Last Post: 02-02-2008, 11:22 PM
  3. Sony vegas resize multiple events
    By jkjohns in forum Sony Vegas video editing apps
    Replies: 1
    Last Post: 02-17-2007, 04:00 PM
  4. Kill Bond
    By B. Brown in forum User Videos
    Replies: 6
    Last Post: 07-14-2006, 06:19 PM
  5. How do i kill?
    By CadburyBeaver in forum Technology advice and tips
    Replies: 22
    Last Post: 07-24-2005, 09:37 PM

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •