Page 1 of 4 123 ... LastLast
Results 1 to 10 of 38

Thread: Masks go haywire when rendering

  1. Default Masks go haywire when rendering

    Cosidering the number of times we had to plead for help making our 1st music video, things have been going fantastically well with the 2nd one.
    Until today!!
    Everything looks fine in the preview pane but when we render down, some of the masks we've created go stupid & cut like half the picture out.
    Yet on examination the masks look perfect.
    We cant understand why this is happening but would be extremely grateful if anyone could tell us how to stop it.

    Thanks


    Sarah & Allison & Tina

  2. #2
    Join Date
    Jan 2005
    Location
    Warsop, Nottinghamshire.
    Posts
    4,465
    Blog Entries
    2

    Default

    Are you using keyframes to move the masks at all? If so - just check the transition of the mask between the keys - you may have an error there....

  3. #3

    Default

    Something similar came up the other day and it was found that the properties of the clips and FX were being mixed. So you could check that the clips and the masks are all the same propertise.eg clip is 4:3 ratio mask is 16:9 ratio. I think there is a button you can click to match the clip properties in the Pan/crop tool.

    It's worth a look.

  4. Default

    Thanks for replies.
    We are not using keyframes on the mask so it cant be that.

    Midnight could you tell us how we check these ratios you mentioned.
    I'm sorry, I cant find anything to do with them!!


    Sarah

  5. #5

    Default

    Just right click the clip and select properties. Check out the size and the pixel aspect ratio match with each other. I don't know if there is a fast way to do this other than checking one clip at a time.

  6. Default

    And we thought we'd come a long way since the 1st video!
    Midnight i'm sorry I dont understand.
    The pixel aspect ratio of the clip is 1.3333, I've no idea what the size is, unless you mean 1440x1080x12 ?
    I cant find any size information in the pan crop tool.

    "So you could check that the clips and the masks are all the same propertise.eg clip is 4:3 ratio mask is 16:9 ratio. "

    I dont know what you're saying here or how to check it?

    "I think there is a button you can click to match the clip properties in the Pan/crop tool".

    Could anyone point out where this button is?

    The worst affected clip was shot with the camcorder rotated at 90degrees, would this have any bearing on it?
    But it's happened to some normal clips aswell.

    Feeling stupid

    Sarah

  7. #7

    Default

    Quote Originally Posted by Sarah & Allison View Post
    And we thought we'd come a long way since the 1st video!
    Midnight i'm sorry I dont understand.
    The pixel aspect ratio of the clip is 1.3333, I've no idea what the size is, unless you mean 1440x1080x12 ? Yes this is the size
    I cant find any size information in the pan crop tool.

    "So you could check that the clips and the masks are all the same propertise.eg clip is 4:3 ratio mask is 16:9 ratio. "

    I dont know what you're saying here or how to check it? So long of the size is the same on all video track thats fine

    "I think there is a button you can click to match the clip properties in the Pan/crop tool".

    Could anyone point out where this button is? My bad there is no button on this tool.

    The worst affected clip was shot with the camcorder rotated at 90degrees, would this have any bearing on it? No
    But it's happened to some normal clips aswell.

    Feeling stupid Don't, I wouldn't talk to you if you were stupid. Stupid is when you think you know but don't. Simply not knowing isn't stupid. It's just not know, there is a big difference.

    If this was stupid because I don't know either I just have some ideas that you can check.

    Sarah
    So make sure your project properties and ALL your clips are the same.

    This may or may not solve it but if not we can try something else until we do however frustrating it may get for you. OR till Grazie comes along or one of the others that really knows Sony Vegas inside out.

  8. Default

    Thank you for your perseverance with this.
    I was not saying you were making me feel stupid I was simply admitting to the fact we are here on a video makers website with little knowledge of what we are actually doing, attempting to make music videos with limited interest in photography & that is pretty shameful.

    I have been reading in my Vegas manual & experimenting with different settings & now understand better the things you suggested, but to no avail.

    The only thing I have found that sort of works is to draw a ridiculously huge area with the masking tool way beyond the portion of the clip that is being cut off out beyond the picture. This restores the missing bit on rendering but its impossible to predict what else will be included.


    Sarah

  9. #9

    Default

    Please supply a SCREENGRAB of your area of working. At the moment I can not visualise what the issue is? You might also wish to post the VEG here too.

  10. Default

    Thank you for your interest Grazie.
    Not sure if I've attached what you asked for but I include screen captures of the Pan crop pane, the Preview Pane on Good Auto & then on Preview Auto, and the Mask.
    In doing this I have just discovered changing the setting of the Preview pane from preview auto to good auto produces the same cropping effect as rendering the file. (I have always had it on Preview Auto).
    Will post the .veg file when I can work out how to do it!


    Sarah
    Attached Images Attached Images
    Last edited by Sarah & Allison; 02-12-2010 at 12:11 AM.

Page 1 of 4 123 ... LastLast

Similar Threads

  1. Masks not in right place when rending to mpg or wmv
    By fixxxer76 in forum Sony Vegas video editing apps
    Replies: 3
    Last Post: 03-17-2009, 12:11 AM
  2. Moving Masks?
    By HelpPlz in forum Sony Vegas video editing apps
    Replies: 3
    Last Post: 05-15-2008, 08:08 AM
  3. Premiere Elements 4.0: Drawing masks?
    By Subzero1233 in forum Adobe Premiere, Premiere Elements, and After Effects
    Replies: 1
    Last Post: 02-04-2008, 04:41 PM
  4. Problems saving after using masks
    By Rel in forum Sony Vegas video editing apps
    Replies: 1
    Last Post: 10-10-2007, 03:02 PM
  5. layer masks in premiere
    By FuryX721 in forum Adobe Premiere, Premiere Elements, and After Effects
    Replies: 2
    Last Post: 01-25-2006, 01:18 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •