Until recently I've always converted to Xvid using one pass, but having got a new 50" TV which is a lot more unforgiving I am trying to get superior XVid encodes. Thus two pass encodes & a target size I dictate (in theory)

I am trying to convert a 45 minute DVD Rip (mpg) to a 350 - 358MB file size which includes audio at around 41mb (Lame mp3 128Kbps) . I find the various tv downloads, medium, supernatural, smallville etc are all around 350 - 358mb & all are very good quality.
Everytime I put the Target Size in it always converts bigger. I've hunted around various forums & tried various different settings & tweaks but cannot get it to be at what I set it for.

I'll post my settings here & if anyone could advise I would be very grateful.

XVid Settings

Profile @ Level - Advanced Simple @ L5
Quantization Type H.263
Adaptive Quantization: Luminance-Masking
Interlaced Encoding, B-VOPs & Packed BItstream (checked)
Max Consecutive BVOPs: 1
Quantizer ratio: 1.50
Quantizer offset: 1.00

Encoding Type
Twopass - 1st pass
Full quality pass (unchecked)
Discard first pass (checked)

Encoding Type
Twopass - 2nd pass
All default settings except I have tweaked
Overflow control strength
Max overflow improvement
Max overflow degradatio
All from their original 10 & have tried 15 & 20 as various guides state these will force a file to be the size set. But it didn't

Target Size = 319488 (312mb)

Start Frame 0
Weight: 1.00
Chroma optimizer enabled (checked)
All else unchecked

Quality Presets - User Definded (more)
Motion Search: 6 - Ultra High
VHQ Mode: 1 - Mode Decision
VHQ Mode
Use VHQ for bframes too, Use Chromas motion & Turbo all checked.
Frame drop ratio: 0
Maximum I-frame interval: 300

All min(s) at 2
All max at 31
Trellis quantization (checked)

FourCC Used: XVID
Number of threads: 0
All rest of other set at default.

I then make sure 1st pass is selected, choose Save As, put 1st pass in the file name & check run job later.
I then change to 2nd pass, choose Save As, put 2nd pass in the file name & again check run job later.

When the job runs & completes I get 2 files
1st pass.avi (45.794KB)
2nd pass.avi (363,605KB)
V Resolution 624*352
Audio 41MB, Lame mp3 128Kbps

Now running this I'm getting a bit of a fuzzy picture & the file size is bigger than I put into the Target Size. The video bitrate is 964Kbps. (I'm having to add the deinterlace filter in Virtualdub, sure this doesn't affect the file size as did an experiment without it previously)

Yet I look at an episode of Supernatural I downloaded which is
358,374KB (41mb Lame mp3 128Kbps - V Resolution 624*352)
Great picture, smaller file size.

Can anyone give me some pointers quick as I don't have too much more hair to pull on!!!