Results 1 to 3 of 3

Thread: XL1 Problem

  1. #1
    Join Date
    Oct 2004
    Location
    Edinburgh
    Posts
    134

    Default XL1 Problem

    Hi, I have a canon XL1 camera and have a slight problem. If any of you know the XL1 then you will know that there are 2 screw holes on the bottom of the camera. (one for tripod plate and one for an xlr shoe). I was using the camera on a monopod and the top of it snaped off leaving part of the screw in the screw hole! (the xl1 one thankfully) What advice can you give me to get round this problem?

    Thanks

    N
    Full Specs: 3.2 Pentium 4 Processor, 1Gb RAM 80Gb Root Drive, 120Gb Video Drive + another 160Gb external, Adobe Premiere Pro, Pinnacle liquid edition pro, ati radion 256mb

  2. #2
    Join Date
    Nov 2003
    Location
    Kent
    Posts
    11,514
    Blog Entries
    24

    Default

    If there's still a bit of the screw sticking out, you can get a pair of plyers on it and unscrew it.

    If you don't mind risking your camera, you can open up the housing at the bottom and see if the screw pokes up the other side. (doubtful). You could source a broken XL1 and replace the base cover with your one.

    Or you could do the sensible thing and take it to an authorised repairer.

  3. #3
    Join Date
    Oct 2004
    Location
    Edinburgh
    Posts
    134

    Default

    Thinking the authorised repair might be the best thing to do.

    Thanks anyway
    Full Specs: 3.2 Pentium 4 Processor, 1Gb RAM 80Gb Root Drive, 120Gb Video Drive + another 160Gb external, Adobe Premiere Pro, Pinnacle liquid edition pro, ati radion 256mb

Similar Threads

  1. problem capturing and a problem with mpg in premier
    By franny in forum Adobe Premiere, Premiere Elements, and After Effects
    Replies: 25
    Last Post: 10-27-2004, 05:36 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •