Results 1 to 8 of 8

Thread: playback problems on Premiere Elements 7

  1. #1

    Default playback problems on Premiere Elements 7

    Hey, I just started using Premiere Elements 7.0 and the program runs pretty well but the playback is unuseable. It jumps or is way off. Is there something I can do to fix this? Without playback its imposible to get anyhthing of quality.
    Any help would be great. Thanks a lot

  2. #2

    Default

    What format are you trying to edit? Some formats work much better than others. AVCHD and MPEG sometimes can cause problems, as well as footage taken from a DVD camcorder.

    Premiere Elements likes DV and/or DV-AVI from a MiniDV tape or DV tape camera.
    There are ways around it by conversion and other methods. Sometimes it is just a simple field order problem.

    Knowing what you are trying to edit will help as well as your system specs
    http://muvipix.com Everything you wanted to know about Premiere Elements and more

  3. #3

    Default

    The videos I'm trying to edit are AVI

    I checked my specs and I dont know what they mean lol maybe you guys could help

    Computer:
    Intel (R)
    Pentium(R) 4 CPU 1400MHz
    1.40GHz, 512MB of RAM

    Thanks Again

  4. #4

    Default

    That is way below the required specs for running Premiere Elements 7, I'm not sure how you even got the program working at all. The terrible playback will be something you will have to live with I'm afraid.

    You should have at least 2GB of RAM and a Pentium 4 2.8ghz or faster processor. I would imagine you have either shared video or a very low end video card as well. You should really have a dedicated video card with at least 256mb of video memory.

    Not sure what size hard drives you have but video work needs lot of free space frequently defragmented. Lots to learn when you first start out.

    I recommend checking out the forum and free help at muvipix.com
    http://muvipix.com Everything you wanted to know about Premiere Elements and more

  5. #5
    Join Date
    Nov 2005
    Location
    Bristol uk
    Posts
    8,938
    Blog Entries
    1

    Default

    Your pc does look a bit slow for editing - however, to a greater or lesser extent the preciew will often lag in any editor. Thats why it's called preview...

  6. #6

    Default

    I have no lag in Premiere Elements on either of my editing workstations. No lag in Premiere Pro either, but my specs on both machines are more than twice what Jordan lists.
    http://muvipix.com Everything you wanted to know about Premiere Elements and more

  7. #7
    Join Date
    Nov 2005
    Location
    Bristol uk
    Posts
    8,938
    Blog Entries
    1

    Default

    Now go add some c correction, gaussian blr, chromakey - now it's laggy - thats what i mean. Any editor will lag under duress. This is normal and not a faulkt of the editor.

  8. #8

    Default

    Mark, the timeline may stutter or lag but the preview is always fine. Haven't come across anything that causes any problems with the preview, HDV, SD, effects, transitions, whatever. Maybe I don't work mine as hard as you do
    http://muvipix.com Everything you wanted to know about Premiere Elements and more

Similar Threads

  1. Adobe Premiere Elements problems
    By Kasey Gray in forum General video editing software help and advice
    Replies: 3
    Last Post: 02-26-2009, 05:58 PM
  2. Premiere Elements broke video playback - can't fix it
    By jamespetts in forum Adobe Premiere, Premiere Elements, and After Effects
    Replies: 1
    Last Post: 03-13-2008, 09:16 AM
  3. Premiere Elements problems
    By andy parr in forum General video editing software help and advice
    Replies: 0
    Last Post: 03-08-2007, 08:40 PM
  4. Premiere Elements with Windows XP SP2 - problems ??
    By MikeyC in forum Adobe Premiere, Premiere Elements, and After Effects
    Replies: 2
    Last Post: 06-30-2005, 07:18 AM
  5. 2 Premiere 6.5 problems- Audio and TV playback
    By Chris in forum Adobe Premiere, Premiere Elements, and After Effects
    Replies: 5
    Last Post: 12-09-2004, 06:19 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •