Results 1 to 4 of 4

Thread: Annoying Slow Premiere Elements

  1. #1

    Default Annoying Slow Premiere Elements playback

    Hey, I know this is something first timers like me ask all time so I thought you guys could help.
    I'm using Premiere Elements 7 on a windows XP and the program is pretty much unusable because its so slow. I cant get any idea of what im doing because the video goes really slow. My computer is pretty normal and doesnt have to many problems with speed. Also, I seem to have more than enough space on my computer even though I do have a lot of stuff on it. I have had this problem with pretty much every program I use can any one explain this.

    So I'm asking is there a way to fix this or is it just my computer?
    would you suggest for me to buy a laptop?

    Thanks for anything you can help with and I look forward to reading the responces
    Last edited by Jordan33; 01-31-2009 at 11:31 PM.

  2. #2
    Join Date
    Nov 2008
    Location
    Peterborough, Ontario
    Posts
    94

    Default

    If I were you I'd make sure that you don't have a bunch of stuff running in the background, especially scheduled tasks. If you do turn them off. Go into the Task Manager and start cutting processes that you don't need. Make sure something isn't using up all your RAM.

    If you finnd this helps, run msconfig and disable startup programs you don't need and disable some services that you don't need.

    BTW, what's a labtop?

  3. #3
    Join Date
    Jul 2004
    Location
    Manchester, UK
    Posts
    1,893

    Default

    Could do with posting the specs of your laptop really:

    - Amount of memory
    - Processor model
    - Amount of free hard drive space
    - What format are you using? (Apparently AVCHD causes issues in Elements 7)

    Should be able to give a better idea knowing that.

    Cheers

    Mike

  4. #4
    Join Date
    Jul 2004
    Location
    Manchester, UK
    Posts
    1,893

    Default

    Could do with posting the specs of your laptop really:

    - Amount of memory
    - Processor model
    - Amount of free hard drive space
    - What format are you using? (Apparently AVCHD causes issues in Elements 7)

    Should be able to give a better idea knowing that.

    Cheers

    Mike

Similar Threads

  1. playback in premiere way too fast/slow
    By rtil in forum Adobe Premiere, Premiere Elements, and After Effects
    Replies: 5
    Last Post: 12-13-2008, 08:56 PM
  2. Slow Motion with Adobe Premiere 6.5
    By chrisobrien7 in forum Adobe Premiere, Premiere Elements, and After Effects
    Replies: 3
    Last Post: 02-08-2008, 04:12 PM
  3. Is Elements 2.0 slow? Or is it me?
    By Rob in forum Adobe Premiere, Premiere Elements, and After Effects
    Replies: 4
    Last Post: 07-19-2006, 04:22 PM
  4. Adobe Premiere Elements 1-Slow Moton set area of clip
    By Dan442 in forum Adobe Premiere, Premiere Elements, and After Effects
    Replies: 1
    Last Post: 07-15-2005, 04:59 PM
  5. Does Premiere Elements 1 work with Photoshop Elements 2?
    By Matty Boy in forum Adobe Premiere, Premiere Elements, and After Effects
    Replies: 3
    Last Post: 03-28-2005, 08:45 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •