Results 1 to 6 of 6

Thread: Canon 750i firewire problem

  1. #1
    Join Date
    Sep 2008
    Location
    near Malaga
    Posts
    4

    Default Canon 750i firewire problem

    Hi! Not sure from which angle this problem should be dealt with but here goes. Up until a week ago my canon 750i connected perfectly with my G5 but now for some strange reason it has stopped being recognized. I have a JVC camcorder which is working OK in the mac so I know its not the firewire port and Ive also reset the PMRA. Has anyone got any thoughts?

  2. #2
    Join Date
    Aug 2005
    Location
    Western Europe
    Posts
    3,409

    Default

    It may not be the firewire port on your computer that has the problem but it might be the firewire port on your Canon? Have you tried it with another firewire cable to see if it works?

  3. #3
    Join Date
    Sep 2008
    Location
    near Malaga
    Posts
    4

    Default

    hi! Not tried another cable because I have a JVC camcorder that work perfectly-besides its a belkin cable and they do appear to be pretty robust-its just so starnge that the canon 750i is suddenly not being recognized. I have a friend coming round on friday who has a mac laptop so I'm going to try it in that.

  4. #4
    Join Date
    Sep 2008
    Location
    near Malaga
    Posts
    4

    Default

    friend cam round with his mac laptop and did not recognize canon 750i-looks like a repair job?

  5. #5
    Join Date
    Aug 2005
    Location
    Western Europe
    Posts
    3,409

    Default

    Sounds like the firewire socket on your Canon is busted. Get a quote first before deciding to get it fixed, it may work out cheaper to buy a new camcorder (not Canon) if it happens a second time.

  6. #6
    Join Date
    Sep 2008
    Location
    near Malaga
    Posts
    4

    Default

    many thanks! not the sort of news I wanted but all indications seem to point to the socket. Im surprised you said dont get a canon.. any advice on a camera in the same price range that will convert av to dv?

Similar Threads

  1. Canon 750i minidv camera just gone 'blank' in record mode
    By ircoha in forum Technology advice and tips
    Replies: 5
    Last Post: 09-29-2008, 06:27 PM
  2. Canon ZR-500 & Firewire
    By ashleenilsson in forum Hardware Problems
    Replies: 1
    Last Post: 12-28-2006, 09:46 PM
  3. Canon m20i Firewire Capture Problem
    By Derek46 in forum General video editing software help and advice
    Replies: 0
    Last Post: 07-10-2006, 11:55 AM
  4. Help!! Canon XL1 Firewire issue
    By Nalehp in forum Hardware Problems
    Replies: 6
    Last Post: 02-22-2006, 11:31 PM
  5. Canon MV550i - Firewire
    By Daisy in forum Hardware Problems
    Replies: 2
    Last Post: 03-07-2005, 06:11 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •