Results 1 to 6 of 6

Thread: Rendering and interlacing-lines

  1. #1

    Default Rendering and interlacing-lines

    SO, as i wrote in my other thread ("interlacing and resolution issues!") lines keep eliminating my attempts to create a watchable DVD of the movie i made. At first it seemed the problem originated in the small fact that i watched the clip on my computerscreen (aka "progressive"-screen) but now i have realized that the lines are still there even on television (whatever happened to televisions viewing material with dots instead of lines?). I use Field order: None (progressive) and Deinterlace method: None in project video properties and Field order: None (Progressive) in the render settings. the problem appear in both AVI and MPEG 2-format.

    This site describes the problem in the faq section and redirects to another quite extensive site. The problem though is that the guy thats made the site has made everything extremely confusing not to mention completely unrelated to the functions of Sony vegas. An expert could probably process this information efficiently but i just feel completely lost while scrolling trough the site.

    Now, if i have used a PAL miniDV camera to record the material:

    1. Is the material recorded progressively or interlaced?

    2. If the material is shot in 50 fps, what should i render it to since 50 fps isnīt a selectable frame rate in render settings?

    3. If itīs progressive what settings do i choose in Sony vegas?

    4. If itīs interlaced what settings do i choose in Sony Vegas?

    5. Is there a way of fixing it without sacrificing quality?

    The final question is based on the fact that i found it possible to render down to 24 fps which made the lines go away but the quality worse. How is this possible? What makes the lines turn from being lines that moves in a hypnotic fashion on the tv even while paused, to become clear though blurry white fields?
    I donīt want to (and donīt think i should have to) sacrifice the quality in the version with the lines but i have to get rid of the lines in order for the film to be watchable.

    Could it have to do with the format? I chose mpeg 2 and DVD architect PAL video stream and then in custom i chose DVD as output type. Other output-choices in render settings are SVCD, HDV, ATSC, D-VHS and MPEG 2.

    Or could it perhaps have to do with downsizing ? Thereīs alot of talk about the need for resizing to solve these kinds of issues but no real reasons why resizing solves interlacing-issues and no directions as to how this resizing should take place.

    As mentioned in the previous post the problem sticks around regardless of which deinterlace method i use (Blend, Interpolate and None-progressive) so it seems to have to do with something else.

    I would REALLY appreciate help with this. Iīve been trying to fix it for a couple of weeks now and iīm starting to completely freak out (as you perhaps already have noticed). And even if you personally donīt know what i should do then perhaps you could redirect me to some Sony vegas-Interlacing-dvd-guru somewhere that can help me instead!? I would be VERY grateful!

  2. #2

    Default

    For tv destination,ie dvd,then render as interlaced, upper field first.
    Use the mainconcept mpeg-2 template,make sure on the audio tab "include audio" is checked.
    Here's my vegas template.
    Hope this helps.

    Paul.
    Attached Images Attached Images

  3. #3

    Default

    Tried it but unfortunately it didnīt work. Iīm not experiencing any difference except for perhaps a slight increase in Interlacing-intensity (and i donīt mean that in a good way). However i did find a solution just now. Itīs not a 100 percent flawless solution and iīm not sure what consequences it will have but iīm still going to try and burn a dvd with these settings:

    If i render down from 50 fps to 24 fps instead of from 50 fps to 25 fps the lines disappear, i get minimal loss of quality (although still noticeable) and minimal artifacts.
    How this is possible is for me impossible to comprehend.

    Iīve read about 24fps and found out that itīs often used in music videos which are then converted to 25 fps before viewing. It seems to have to do with the speed (4% differential between 24 and 25). Now a possible threat that could emerge when rendering using this method i guess would be the audio getting unsynched. But i guess thereīs no real way (at least no easy way) to find out if this is true other than by simply rendering the whole movie and see for myself. This i will attempt tomorrow evening.
    Thanks for the tip though!

    Even though i have come up with a possible solution some additional views and facts i should take into consideration are still very much welcome to say the least. This thing i came up with may not work at all so if you got some info, please share. Iīm not out of the woods just yet...

  4. #4

    Default

    You shouldn't have to be going through all this crap with vegas, just to be getting a watchable DVD.
    When you've got clips on the timeline,right click on a clip and it'll show you the properties,ie frame size and upper or lower or interlaced field etc. Set the project preferences as the same,you're probably doing all this anyway,but from what i gather,this doesn't effect the final outcome,that's decided by the render template.
    I use the template which i posted if i film in interlaced or progressive.
    Paul.

  5. #5
    Join Date
    Feb 2006
    Location
    Surrey, UK
    Posts
    10,844
    Blog Entries
    1

    Default

    Quote Originally Posted by Kronblom View Post
    Now, if i have used a PAL miniDV camera to record the material:

    1. Is the material recorded progressively or interlaced?

    2. If the material is shot in 50 fps, what should i render it to since 50 fps isnīt a selectable frame rate in render settings?

    3. If itīs progressive what settings do i choose in Sony vegas?

    4. If itīs interlaced what settings do i choose in Sony Vegas?

    5. Is there a way of fixing it without sacrificing quality?

    ...

    Or could it perhaps have to do with downsizing ? Thereīs alot of talk about the need for resizing to solve these kinds of issues but no real reasons why resizing solves interlacing-issues and no directions as to how this resizing should take place.
    My understanding...(and it's no more than that so I really hope I don't muddy the water by posting innacuracies)

    1. Is the material recorded progressively or interlaced?

    Interlaced

    2. If the material is shot in 50 fps, what should i render it to since 50 fps isnīt a selectable frame rate in render settings?

    It is shot in 50 FIELDs per second not FRAMES per second. It is 50i where the i is for interlaced. You are already aware that this means the odd numbered lines making up the image (one field) are shot then the even number of lines are shot (another field) and thus to make up a whole picture you need to combine the odd and the even. However, given that these FIELDS are shot 1/50th second apart, where there is movement the resultant image will have the comb effect. This is absolutely fine when played back on a TV which alternately plays back the even and odd lines.

    This can be easily demonstrated by capturing from MiniDV and loading onto the timeline. Assuming project properties are set to PAL (and your footage was PAL) Vegas displays 25 FRAMES per second on the timeline. One FRAME on the timeline comprises one even FIELD and one odd FIELD. Zoom in on the preview and you can clearly see this.
    If you simply take this and output a PAL MPEG2 DVD it will look EXACTLY the same on a TV as direct from the camera.

    (I'm not sure of the numbers in the following, but I think the principle is correct)..

    The problem occurs when you zoom or crop.

    Your interlaced 1/25th sec frame is made up of 625 (that's the number I'm unsure of) lines.
    If you zoom in a bit, your now looking at an image of say 500 lines. But this image needs to be re-split into 625 lines for display on a device expecting interlaced output. Obviously the odd/even lines don't match any more.

    The way around this is to de-interlace the image first so that instead of each frame being made up of two fields 1/50th sec apart, you get a single frame (progressive).

    This frame has to be calculated based on the original two fields and this is where your compromise takes place - and hence your loss in quality. There is no panacea here, you just have to try different methods of deinterlacing to get the best quality.

    One method is to deinterlace & render (you can use programs other than Vegas) those sections you want to crop before pulling them into your project.

    I feel for you - I had similar problems and I now try to avoid any sort of zooming.

    The strange thing is, since I've become aware of the problem and gone some way to understanding it, I haven't really suffered it.



    I hope others with a better undertsanding will elaborate and correct.
    Tim

  6. #6

    Default

    Quote Originally Posted by Kronblom View Post
    I use Field order: None (progressive) and Deinterlace method: None in project video properties and Field order: None (Progressive) in the render settings.
    It sounds to me like you have maybe told your NLE that the project is progressive when your source is interlaced?

    I could imagine if that were the case that it would never deinterlace properly?

    I had similar issues with Premiere when I started editing, and the solution I used was to open a second copy of premiere, start an interlaced project in that, and copy and paste the timeline from the old (progressive) project to the new (interlaced) project. The OLE was smart enough to take all the clips from the old project and assemble the clips in the new project.

    Before trying this, I would try starting a new project and dropping a clip in it. If you are able to render it out OK you know you are on the path to deinterlaced goodness.

    Oh, and BTW, for anyone new to interlacing, this page is really useful. The Bob+Weave deinterlace method detailed gives double frame rate output which is awesome for silky smooth slowmos.

Similar Threads

  1. Interlacing
    By Gunner7 in forum Sony Vegas video editing apps
    Replies: 8
    Last Post: 02-14-2008, 03:49 PM
  2. interlacing /de-interlacing advice please
    By davo in forum General video editing software help and advice
    Replies: 1
    Last Post: 07-28-2006, 03:07 PM
  3. de interlacing
    By FNG in forum Adobe Premiere, Premiere Elements, and After Effects
    Replies: 2
    Last Post: 03-21-2006, 04:52 PM
  4. seems like interlacing
    By david walsh in forum Forum Announcements and News
    Replies: 9
    Last Post: 02-02-2006, 06:41 AM
  5. Horrible looking lines after rendering
    By pepijnaccou in forum Adobe Premiere, Premiere Elements, and After Effects
    Replies: 7
    Last Post: 03-03-2004, 07:01 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •