Results 1 to 3 of 3

Thread: Video camera not detected?

  1. #1

    Default Video camera not detected?

    I am trying to import video from my Canon MV800 onto my laptop. I have been trying Windows Movie Maker, but every time I click on 'Import from digital video camera' I get the error message: Import Video could not find a compatible digital video device.' The same problem occurs in Ulead VideoStudio 11. I have tried switching my camera off and on again, as the Help menu states, but to no effect. I also read on the internet somewhere that a Firewall can restrict connection, but I have turned it off.

    I am using a Belkin Firewire cable connected to my Windows Vista Home Premium laptop via a Firewire Express Card. The Firewire cable has always worked in the past, when I used to import video from the same camcorder but to an Apple laptop with an integral Firewire port. The Express Card is new, I have never used it before, but when I first inserted it the laptop acknowledged it was there (with that telltale beep noise!) and installed the relevant software automatically, so I assume there is no problem there.

    I really have no idea what to try now.

    Any help would be greatly appreciated, I'm trying to do my brother's wedding footage but I can't even get past this simple step!

    Thank you in advance.

  2. Default

    Well you could check using the following:

    - Windows Menu -> Settings -> Control Panel
    - System Icon
    - Hardware tab
    - Device Manager

    Check under the appropriate container to see if your Express card is registered properly and is working.

    If it is, can you try an alternate cable?

    If this doesnt work you may want to take out the card, remove the Express Card device from the Device Manager (as instructed above) or uninstall it and put it in and reinstall it!

    As for the tell-tale beep - shouldnt you also get one when you turn the camera on?

    Have you tried using it with other s/w other than the ones you indicate in your above post?

  3. #3


    Yeah I called an IT helpline and they said to look at Device Manager, but yes the IEEE connection is there and appears and disappears accordingly when I insert and remove the Firewire card.

    I went to PC World and they tried another cable - nothing happened.

    Yeah the man from the IT Helpline said to try downloading the trial version of Adobe Premier and seeing if that picks it up, but it didn't.

    I tried calling the Canon helpline and they couldn't help me either. I really am at my wit's end. What I'm going to to do is go back to PC World to test everything - ie, try my camcorder on another laptop with Windows Vista, and try my laptop with another Firewire device. It's difficult to test on your own when you don't have the equipment.

    Thanks for trying to help, I'll let you know what happens.

Similar Threads

  1. Camcorders no longer detected
    By jamesuk1981 in forum General video editing software help and advice
    Replies: 1
    Last Post: 11-04-2006, 10:27 PM
  2. premiere 2.0 pro, dvd burner not detected
    By Ken Ritter in forum Adobe Premiere, Premiere Elements, and After Effects
    Replies: 5
    Last Post: 10-14-2006, 02:48 AM
  3. Sony Camera not detected
    By carlos in forum Hardware Problems
    Replies: 5
    Last Post: 01-25-2006, 10:40 AM
    By JROL in forum General video editing software help and advice
    Replies: 1
    Last Post: 01-16-2006, 04:17 PM
  5. TV Card not detected at all!
    By ripperjacklevel9 in forum Hardware Problems
    Replies: 0
    Last Post: 03-23-2004, 11:22 AM


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts